<!DOCTYPE html><!-- HTML 5 -->
<html lang="en">

<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<title>New Music: Curren$y ft. Young Roddy &#8211; Long As It Lasts | UNCUTmagazine.net</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://uncutmagazine.net/xmlrpc.php" />

<!--[if lt IE 9]>
<script src="https://s0.wp.com/wp-content/themes/premium/dynamic-news/js/html5shiv.js" type="text/javascript"></script>
<![endif]-->
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=uncutmagazine.net&amp;id=6828512&amp;t=1510967783&amp;back=https%3A%2F%2Funcutmagazine.net%2F2017%2F11%2F17%2Fnew-music-curreny-ft-young-roddy-long-as-it-lasts%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//uncutmag.wordpress.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="UNCUTmagazine.net &raquo; Feed" href="https://uncutmagazine.net/feed/" />
<link rel="alternate" type="application/rss+xml" title="UNCUTmagazine.net &raquo; Comments Feed" href="https://uncutmagazine.net/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="UNCUTmagazine.net &raquo; New Music: Curren$y ft. Young Roddy &#8211; Long As It&nbsp;Lasts Comments Feed" href="https://uncutmagazine.net/2017/11/17/new-music-curreny-ft-young-roddy-long-as-it-lasts/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1505864856h&ver=4.9-20171117"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56794,8205,9794,65039],[55358,56794,8203,9794,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s2.wp.com/_static/??-eJyVkOFuQiEMhV9ojNxEnfux7FkQumuVAqG9ud63F8TN6BYW/5DTph/ntHpOysYgEETTpJKfRgys52QjKSb0sDxUr5b5Rf+NeTwC6wNIMvaoLlVvPIM3Ak6lyPJQ9TAbM5Q+JSN1gsChAQ9UxnrYjG6E4lNGrloJnLoIpc23UZX7slU3WTvUbpcyMKvyEk6kZF+y/bMR1fTtYpeAd52Gog5RsND8I3792az01Vm7JRhCqwLMrFkWD08RNcgIAXJzvcmnf/nycGKPDnJFP+ljWL1vtm/Ddj0czoAa8vo=' type='text/css' media='all' />
<link rel='stylesheet' id='dynamicnews-droid-sans-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans%3A400&#038;ver=4.9-20171117' type='text/css' media='all' />
<link rel='stylesheet' id='dynamicnews-francois-one-css'  href='https://fonts.googleapis.com/css?family=Francois+One%3A400&#038;ver=4.9-20171117' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-4-1' href='https://s2.wp.com/_static/??-eJyVjkEOwjAMBD+EiQJIwAHxFjdNI1MnjupUhd8TDgh6KeU2I+1YNlMGJ6n4VEwcIfMYKKmZqA2+qCmSIYtW0vJgv3WqG7OcdOh8I9IDU1/hvr6sXDAMGD+0JlNxhAxUJ3P5I46+JXyf+PVv8AIsDgtJmgl0jDQspYNvWELFYOrqS1/RNV7s4Xzcnazd29sTwFSafw==' type='text/css' media='all' />
<link rel='stylesheet' id='print-css-5-1' href='https://s0.wp.com/wp-content/mu-plugins/global-print/global-print.css?m=1465851035h' type='text/css' media='print' />
<link rel='stylesheet' id='all-css-6-1' href='https://s2.wp.com/_static/??-eJx9i9EKwjAMRX/IGoVN54P4LVnp2kialCbD3xcfRGTi0z0XzoFHC1HFkzjUNTReM4kBRieVGfuH9tFsB7/1puZhYaQOVrCT5Pf+q0wjIQfWrN9nE3lJNRmUATLrjPwSbvV6HC6H83Qap/H+BMWZScE=' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var DynamicNewsSliderParams = {"animation":"horizontal","speed":"7000"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJydkGEKwjAMhS9kVwZT8Yd4lrrFmdmktWk39fR2oKBTFIVASPK98BI9eIVc29SA6C7HMUE431LRyUx/AhRhG0yEgpDvcO04AseRJbdFCyoJBNPmXl60c2847yQSiGTozfTZEnKPMHzFOoje1AcVQPDyspWS8ja1yKID2HxAo0YPk2qqinvILrUPQJhIN2c2hLViGB4+U+wsnMRiA+FH/V8iNj22JqIb/7+hdVmt5uW8qpaL7gqW97Lf'></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1377793621h' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://uncutmag.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='New Video: Statik Selektah feat. Conway, Westside Gunn &amp; Termanology &#8211; No.&nbsp;8' href='https://uncutmagazine.net/2017/11/17/new-video-statik-selektah-feat-conway-westside-gunn-termanology-no-8/' />
<link rel='next' title='New Video: Remy Ma ft. Lil&#8217; Kim &#8211; Wake Me&nbsp;Up' href='https://uncutmagazine.net/2017/11/17/new-video-remy-ma-ft-lil-kim-wake-me-up/' />
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://uncutmagazine.net/2017/11/17/new-music-curreny-ft-young-roddy-long-as-it-lasts/" />
<link rel='shortlink' href='https://wp.me/psEpi-adD' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Funcutmagazine.net%2F2017%2F11%2F17%2Fnew-music-curreny-ft-young-roddy-long-as-it-lasts%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Funcutmagazine.net%2F2017%2F11%2F17%2Fnew-music-curreny-ft-young-roddy-long-as-it-lasts%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="New Music: Curren$y ft. Young Roddy &#8211; Long As It Lasts" />
<meta property="og:url" content="https://uncutmagazine.net/2017/11/17/new-music-curreny-ft-young-roddy-long-as-it-lasts/" />
<meta property="og:description" content="Spitta links up with Young Roddy for a new track called &#8220;Long As It Lasts&#8221;. No word on what this will appear on but knowing Curren$y it could just be a loosie. &nbsp;" />
<meta property="article:published_time" content="2017-11-17T23:40:43+00:00" />
<meta property="article:modified_time" content="2017-11-17T23:26:38+00:00" />
<meta property="og:site_name" content="UNCUTmagazine.net" />
<meta property="og:image" content="https://uncutmag.files.wordpress.com/2017/11/curreny-ft-young-roddy-e28093-long-as-it-lasts.jpg" />
<meta property="og:image:secure_url" content="https://uncutmag.files.wordpress.com/2017/11/curreny-ft-young-roddy-e28093-long-as-it-lasts.jpg" />
<meta property="og:image:width" content="450" />
<meta property="og:image:height" content="293" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@Uncut_Magazine" />
<meta name="twitter:text:title" content="New Music: Curren$y ft. Young Roddy &#8211; Long As It&nbsp;Lasts" />
<meta name="twitter:image" content="https://uncutmag.files.wordpress.com/2017/11/curreny-ft-young-roddy-e28093-long-as-it-lasts.jpg?w=1400" />
<meta name="twitter:card" content="photo" />
<meta name="twitter:creator" content="@Uncut_Magazine" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />
<link rel="shortcut icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/a8dbc2a8eada1bca9b728be42a57c79c?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/a8dbc2a8eada1bca9b728be42a57c79c?s=32" sizes="16x16" />
<link rel="apple-touch-icon-precomposed" href="https://secure.gravatar.com/blavatar/a8dbc2a8eada1bca9b728be42a57c79c?s=114" />
<link rel='openid.server' href='https://uncutmag.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://uncutmag.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://uncutmagazine.net/osd.xml" title="UNCUTmagazine.net" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<meta name="theme-color" content="#050505" />
<style type="text/css">
			@media only screen and (min-width: 60em) {
				#wrapper {
					margin: 0;
					width: 100%;
					max-width: 100%;
					background: none;
				}
				#header {
					padding: 3em 0.5em;
				}
				.container {
					max-width: 1340px;
					width: 92%;
					margin: 0 auto;
					-webkit-box-sizing: border-box;
					-moz-box-sizing: border-box;
					box-sizing: border-box;
				}
				#wrap {
					padding: 1.5em 0;
				}
			}
			@media only screen and (max-width: 70em) {
				.container {
					width: 94%;
				}
			}
			@media only screen and (max-width: 65em) {
				.container {
					width: 96%;
				}
				#wrapper {
					background: #fff;
				}
			}
			@media only screen and (max-width: 60em) {
				.container {
					width: 100%;
					margin: 0;
					-webkit-box-sizing: border-box;
					-moz-box-sizing: border-box;
					box-sizing: border-box;
				}
				#wrap {
					padding: 1.5em 1.5em 0;
				}
			}
		</style><meta name="application-name" content="UNCUTmagazine.net" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Hip Hop In It&#039;s Rawest Form" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://uncutmagazine.net/feed/;icon-uri=https://secure.gravatar.com/blavatar/a8dbc2a8eada1bca9b728be42a57c79c?s=16" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="title" content="New Music: Curren$y ft. Young Roddy &#8211; Long As It&nbsp;Lasts | UNCUTmagazine.net on WordPress.com" />
<meta name="description" content="Spitta links up with Young Roddy for a new track called &quot;Long As It Lasts&quot;. No word on what this will appear on but knowing Curren$y it could just be a loosie. &nbsp;" />
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #050505; background-image: url("https://uncutmag.files.wordpress.com/2015/04/fence.jpg"); background-position: left top; background-size: auto; background-repeat: repeat; background-attachment: scroll; }
</style>
<link rel="amphtml" href="https://uncutmagazine.net/2017/11/17/new-music-curreny-ft-young-roddy-long-as-it-lasts/amp/" /><style type="text/css" id="syntaxhighlighteranchor"></style>
<style type="text/css" id="custom-colors-css">input[type=submit],#mainnav-menu a:hover,#mainnav-menu ul a:hover,.widget-tabnav li a,.postinfo .meta-category a:hover,.postinfo .meta-category a:active,.more-link span,.read-more,#social-icons-menu li a,.bypostauthor .fn,.comment-author-admin .fn,#commentform #submit,#mainnav-icon:hover,#frontpage-slider-wrap:hover .frontpage-slider-controls a:hover,#social-icons-menu li a:before,.widget-tabnav li a:link,.widget-tabnav li a:visited,.more-link:link,.more-link:visited{color:#0c0c0c}#navi-wrap,#mainnav-menu a:link,#mainnav-menu a:visited,.widgettitle,.postinfo .meta-category a,#social-icons-menu li a:hover,#footer-widgets .widgettitle,#footer-widgets .widget ul,#footer-widgets .widget div,#footer-wrap,#frontpage-slider .zeeslide .slide-entry,.frontpage-slider-controls .zeeflex-direction-nav a:before,#frontpage-slider .zeeslide .slide-title a:link,#frontpage-slider .zeeslide .slide-title a:visited,#footer a:hover,.widget-tabnavi li a:hover,.widget-tabnavi li a:active,#frontpage-slider .zeeslide .slide-more-link,#frontpage-slider .zeeslide .slide-more-link:link,#frontpage-slider .zeeslide .slide-more-link:visited{color:#fff}#footer-widgets .widget a:link,#footer-widgets .widget a:visited,#frontpage-slider .zeeslide .slide-title a:hover,#frontpage-slider .zeeslide .slide-title a:active{color:#ccc}.postmeta,#footer-widgets .widget-tabnav li a{color:#a3a3a3}code,pre,.comment-author .comment-meta{color:#a3a3a3}#frontpage-slider .zeeslide .slide-title{border-color:#ddd}#footer a{color:#a3a3a3}body{background:#050505}a,a:link,a:visited,#logo .site-title,.widget a:link,.widget a:visited,#flickr_badge_uber_wrapper a:link,#flickr_badge_uber_wrapper a:visited,#flickr_badge_uber_wrapper a:hover,#flickr_badge_uber_wrapper a:active,.post-title a:hover,.post-title a:active,.infinite-scroll #infinite-handle span,#image-nav .nav-previous a,#image-nav .nav-next a{color:#d81c1c}input[type=submit],#mainnav-menu a:hover,#mainnav-menu ul a:hover,.postinfo .meta-category a:hover,.postinfo .meta-category a:active,#social-icons-menu li a,.bypostauthor .fn,.comment-author-admin .fn,#commentform #submit,#mainnav-icon:hover,.frontpage-slider-controls .zeeflex-control-paging li a.zeeflex-active{background:#e84747}.widget-tabnav li a,.more-link span,.read-more,#frontpage-slider-wrap:hover .frontpage-slider-controls a:hover,.more-link{background-color:#e84747}.archive-title span{color:#eb8888}#frontpage-slider .zeeslide .slide-entry{border-top-color:#e84747}#logo a:hover .site-title,#logo .site-description,#mainnav-menu ul a,.search-form .search-field,.search-form .search-submit:hover .genericon-search,#wp-calendar tbody #today,.page-title,.post-title,.post-title a:link,.post-title a:visited,.postmeta,.postinfo .meta-category,.archive-title,.post-pagination,.infinite-scroll #infinite-handle span:hover,#image-nav,#comments .comments-title,#respond #reply-title{color:#333}#navi-wrap,.widgettitle,.postinfo .meta-category a,.comment-author .fn,#footer-widgets-bg,#footer-wrap,#frontpage-slider .zeeslide .slide-entry,.frontpage-slider-controls .zeeflex-direction-nav a,#social-icons-menu li a:hover,.widget-tabnavi li a:hover,.widget-tabnavi li a:active{background:#333}.page-title,.post-title,#comments .comments-title,#respond #reply-title{border-bottom-color:#333}#footer-widgets .widget-tabnav li a{color:#333}.postmeta,code,pre,.comment-author,.comment-pagination,.widget-category-posts .more-posts .type-post,#widget-category-posts-columns .category-posts-columns .more-posts .type-post,#footer-widgets .widget-tabnav li a{background:#333}.postmeta,code,pre,.comment-author,.comment-pagination,.widget-category-posts .more-posts .type-post,#widget-category-posts-columns .category-posts-columns .more-posts .type-post,#footer-widgets .widget-tabnav li a{background:rgba(51,51,51,.1)}#footer-widgets .widgettitle{background:#545454}#footer-widgets .widget{background:#3f3f3f}#header-content #header-text{color:#6d6d6d}</style>
</head>

<body class="post-template-default single single-post postid-39285 single-format-standard custom-background mp6 customizer-styles-applied highlander-enabled highlander-light custom-colors">

<div id="wrapper" class="hfeed">

	<div id="header-wrap">

		<header id="header" class="container clearfix" role="banner">

			<div id="logo">

				<a href="https://uncutmagazine.net/" title="UNCUTmagazine.net" rel="home">
								<h1 class="site-title">UNCUTmagazine.net</h1>
							</a>

							<h2 class="site-description">Hip Hop In It&#039;s Rawest Form</h2>
			
			</div>

			<div id="header-content" class="clearfix">
				
		<div id="header-search">
			
	<form role="search" method="get" class="search-form" action="https://uncutmagazine.net/">
		<label>
			<span class="screen-reader-text">Search for:</span>
			<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s">
		</label>
		<button type="submit" class="search-submit">
			<span class="genericon-search"></span>
		</button>
	</form>

		</div>

			</div>

		</header>

	</div>

	<div id="navi-wrap">
		<nav id="mainnav" class="container clearfix" role="navigation">
			<h3 id="mainnav-icon">Menu</h3>
			<ul id="mainnav-menu" class="menu"><li id="menu-item-33029" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-33029"><a href="http://uncutmagazine.net">Home</a></li>
<li id="menu-item-37227" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-37227"><a href="https://uncutmagazine.net/category/podcast/">Podcast</a></li>
<li id="menu-item-33032" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33032"><a href="https://uncutmagazine.net/category/news/">News</a></li>
<li id="menu-item-33030" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-33030"><a href="https://uncutmagazine.net/category/music/">Music</a></li>
<li id="menu-item-33031" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33031"><a href="https://uncutmagazine.net/category/video/">Video</a></li>
<li id="menu-item-33033" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33033"><a href="https://uncutmagazine.net/category/mixtapes/">Mixtapes</a></li>
<li id="menu-item-33035" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33035"><a href="https://uncutmagazine.net/category/exclusives/">Exclusives</a></li>
<li id="menu-item-33034" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33034"><a href="https://uncutmagazine.net/category/eye-candy/">Eye Candy</a></li>
</ul>		</nav>
	</div>

				<div id="custom-header" class="container">
				<img src="https://uncutmag.files.wordpress.com/2015/04/cropped-uncut-banner.jpg" />
			</div>
	
	<div id="wrap" class="container clearfix">

		<section id="content" class="primary" role="main">

		
	<article id="post-39285" class="post-39285 post type-post status-publish format-standard hentry category-music">

		<h2 class="post-title">New Music: Curren$y ft. Young Roddy &#8211; Long As It&nbsp;Lasts</h2>

		<div class="postmeta">
		<span class="meta-date">
		Posted on <a href="https://uncutmagazine.net/2017/11/17/new-music-curreny-ft-young-roddy-long-as-it-lasts/" title="6:40 pm" rel="bookmark"><time datetime="2017-11-17T18:40:43+00:00">November 17, 2017</time></a>		</span>

		<span class="meta-author sep">
		by <a href="https://uncutmagazine.net/author/thewadebloggs/" title="View all posts by Wade Bloggs" rel="author">Wade Bloggs</a>		</span>

			<span class="meta-comments sep">
			<a href="https://uncutmagazine.net/2017/11/17/new-music-curreny-ft-young-roddy-long-as-it-lasts/#respond">Leave a comment</a>		</span>
		</div>

		
		<div class="entry clearfix">
			<p><img data-attachment-id="39286" data-permalink="https://uncutmagazine.net/2017/11/17/new-music-curreny-ft-young-roddy-long-as-it-lasts/curreny-ft-young-roddy-long-as-it-lasts/" data-orig-file="https://uncutmag.files.wordpress.com/2017/11/curreny-ft-young-roddy-e28093-long-as-it-lasts.jpg" data-orig-size="450,293" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Curreny-ft.-Young-Roddy-–-Long-As-It-Lasts" data-image-description="&lt;p&gt;Curren$y ft. Young Roddy &#8211; Long As It Lasts&lt;/p&gt;
" data-medium-file="https://uncutmag.files.wordpress.com/2017/11/curreny-ft-young-roddy-e28093-long-as-it-lasts.jpg?w=400&#038;h=260" data-large-file="https://uncutmag.files.wordpress.com/2017/11/curreny-ft-young-roddy-e28093-long-as-it-lasts.jpg?w=450" class="aligncenter size-medium wp-image-39286" src="https://uncutmag.files.wordpress.com/2017/11/curreny-ft-young-roddy-e28093-long-as-it-lasts.jpg?w=400&#038;h=260" alt="" width="400" height="260" srcset="https://uncutmag.files.wordpress.com/2017/11/curreny-ft-young-roddy-e28093-long-as-it-lasts.jpg?w=400&amp;h=260 400w, https://uncutmag.files.wordpress.com/2017/11/curreny-ft-young-roddy-e28093-long-as-it-lasts.jpg?w=150&amp;h=98 150w, https://uncutmag.files.wordpress.com/2017/11/curreny-ft-young-roddy-e28093-long-as-it-lasts.jpg 450w" sizes="(max-width: 400px) 100vw, 400px" /></p>
<p style="text-align:center;">Spitta links up with Young Roddy for a new track called &#8220;Long As It Lasts&#8221;.<br />
No word on what this will appear on but knowing Curren$y it could just be a loosie.</p>
<p style="text-align:center;"><!--[if lt IE 9]><script>document.createElement('audio');</script><![endif]-->
<audio class="wp-audio-shortcode" id="audio-39285-1" preload="none" style="width: 100%;" controls="controls"><source type="audio/mpeg" src="https://uncutmag.files.wordpress.com/2017/11/11_17_2017-curreny-ft-young-roddy-long-as-it-lasts-youtube.mp3?_=1" /><a href="https://uncutmag.files.wordpress.com/2017/11/11_17_2017-curreny-ft-young-roddy-long-as-it-lasts-youtube.mp3">https://uncutmag.files.wordpress.com/2017/11/11_17_2017-curreny-ft-young-roddy-long-as-it-lasts-youtube.mp3</a></audio></p>
<p>&nbsp;</p>
<div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-39285" class="share-facebook sd-button share-icon no-text" href="https://uncutmagazine.net/2017/11/17/new-music-curreny-ft-young-roddy-long-as-it-lasts/?share=facebook" target="_blank" title="Share on Facebook"><span></span><span class="sharing-screen-reader-text">Share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-39285" class="share-twitter sd-button share-icon no-text" href="https://uncutmagazine.net/2017/11/17/new-music-curreny-ft-young-roddy-long-as-it-lasts/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-39285" class="share-google-plus-1 sd-button share-icon no-text" href="https://uncutmagazine.net/2017/11/17/new-music-curreny-ft-young-roddy-long-as-it-lasts/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://uncutmagazine.net/2017/11/17/new-music-curreny-ft-young-roddy-long-as-it-lasts/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-39285" class="share-linkedin sd-button share-icon no-text" href="https://uncutmagazine.net/2017/11/17/new-music-curreny-ft-young-roddy-long-as-it-lasts/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-39285" class="share-pinterest sd-button share-icon no-text" href="https://uncutmagazine.net/2017/11/17/new-music-curreny-ft-young-roddy-long-as-it-lasts/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-pocket"><a rel="nofollow" data-shared="" class="share-pocket sd-button share-icon no-text" href="https://uncutmagazine.net/2017/11/17/new-music-curreny-ft-young-roddy-long-as-it-lasts/?share=pocket" target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://uncutmagazine.net/2017/11/17/new-music-curreny-ft-young-roddy-long-as-it-lasts/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon no-text" href="https://uncutmagazine.net/2017/11/17/new-music-curreny-ft-young-roddy-long-as-it-lasts/?share=email" target="_blank" title="Click to email"><span></span><span class="sharing-screen-reader-text">Click to email (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div></div>			<!-- <rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
			xmlns:dc="http://purl.org/dc/elements/1.1/"
			xmlns:trackback="http://madskills.com/public/xml/rss/module/trackback/">
		<rdf:Description rdf:about="https://uncutmagazine.net/2017/11/17/new-music-curreny-ft-young-roddy-long-as-it-lasts/"
    dc:identifier="https://uncutmagazine.net/2017/11/17/new-music-curreny-ft-young-roddy-long-as-it-lasts/"
    dc:title="New Music: Curren$y ft. Young Roddy &#8211; Long As It&nbsp;Lasts"
    trackback:ping="https://uncutmagazine.net/2017/11/17/new-music-curreny-ft-young-roddy-long-as-it-lasts/trackback/" />
</rdf:RDF> -->
			<div class="page-links"></div>
		</div>

		<div class="postinfo clearfix">
		<span class="meta-category">
			<ul class="post-categories">
	<li><a href="https://uncutmagazine.net/category/music/" rel="category tag">Music</a></li></ul>		</span>

	</div>

	</article>
		


	<div id="comments">

		
						<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/11/17/new-music-curreny-ft-young-roddy-long-as-it-lasts/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://uncutmagazine.net/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="52d7feeba2" /><input type="hidden" name="_wp_http_referer" value="/2017/11/17/new-music-curreny-ft-young-roddy-long-as-it-lasts/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">

	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" title="Guest">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" title="WordPress.com">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" title="Twitter">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" title="Facebook">
					<span></span>
				</a>
			</li>
			<li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
	
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
				<p class="comment-form-posting-as pa-wordpress"><strong></strong> You are commenting using your WordPress.com account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
				<p class="comment-form-posting-as pa-twitter"><strong></strong> You are commenting using your Twitter account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
				<p class="comment-form-posting-as pa-facebook"><strong></strong> You are commenting using your Facebook account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-googleplus" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y&amp;r=G" alt="Google+ photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="googleplus_avatar" id="googleplus-avatar" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_user_id" id="googleplus-user_id" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_access_token" id="googleplus-access_token" class="comment-meta-googleplus" value="" />
				<p class="comment-form-posting-as pa-googleplus"><strong></strong> You are commenting using your Google+ account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function(){
	var input = document.createElement( 'input' ),
	    comment = jQuery( '#comment' );

	if ( 'placeholder' in input ) {
		comment.attr( 'placeholder', jQuery( '.comment-textarea label' ).remove().text() );
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	jQuery( '#comment-form-identity' ).hide();
	jQuery( '#comment-form-subscribe' ).hide();
	jQuery( '#commentform .form-submit' ).hide();

	comment.css( { 'height':'10px' } ).one( 'focus', function() {
		var timer = setInterval( HighlanderComments.resizeCallback, 10 )
		jQuery( this ).animate( { 'height': HighlanderComments.initialHeight } ).delay( 100 ).queue( function(n) { clearInterval( timer ); HighlanderComments.resizeCallback(); n(); } );
		jQuery( '#comment-form-identity' ).slideDown();
		jQuery( '#comment-form-subscribe' ).slideDown();
		jQuery( '#commentform .form-submit' ).slideDown();
	});
}
jQuery(document).ready( highlander_expando_javascript );
</script>

<div id="comment-form-subscribe">
	<p class="comment-subscription-form"><input type="checkbox" name="subscribe" id="subscribe" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe" style="display: inline;">Notify me of new comments via email.</label></p></div>




<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='39285' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="91696a60e2" /></p>
<input type="hidden" name="genseq" value="1510967783" />
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="236"/></p>			</form>
			</div><!-- #respond -->
	<div style="clear: both"></div>		
	</div>


		</section>

		<section id="sidebar" class="secondary clearfix" role="complementary">

	<aside id="wpcom_social_media_icons_widget-3" class="widget widget_wpcom_social_media_icons_widget"><h3 class="widgettitle">Follow UNCUTmagazine on Social Media</h3><ul><li><a href="https://www.facebook.com/pages/UNCUT-Magazine/269442777346" class="genericon genericon-facebook" target="_blank"><span class="screen-reader-text">Facebook</span></a></li><li><a href="https://twitter.com/UNCUT_magazine" class="genericon genericon-twitter" target="_blank"><span class="screen-reader-text">Twitter</span></a></li><li><a href="https://instagram.com/uncutmagazine" class="genericon genericon-instagram" target="_blank"><span class="screen-reader-text">Instagram</span></a></li><li><a href="https://www.youtube.com/user/UNCUTnation" class="genericon genericon-youtube" target="_blank"><span class="screen-reader-text">YouTube</span></a></li></ul></aside><aside id="text-5" class="widget widget_text"><h3 class="widgettitle">Contact Wade Bloggs</h3>			<div class="textwidget">Editor@uncutmag.net</div>
		</aside><aside id="facebook-likebox-2" class="widget widget_facebook_likebox"><h3 class="widgettitle"><a href="https://www.facebook.com/uncutmagazine.net/">UNCUTMagazine Fan Page</a></h3>		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/uncutmagazine.net/" data-width="340"  data-height="432" data-hide-cover="false" data-show-facepile="true" data-show-posts="false">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/uncutmagazine.net/"><a href="https://www.facebook.com/uncutmagazine.net/">UNCUTMagazine Fan Page</a></blockquote></div>
		</div>
		</aside><aside id="text-4" class="widget widget_text"><h3 class="widgettitle">Disclaimer</h3>			<div class="textwidget">UNCUT Magazine does not store any files.
Everything posted on this site is for promotional use only.
Files downloaded should be kept for no longer then 24 hours and then deleted.
Please support the artists and buy their music.
All music and videos are copyrights to the original owners.</div>
		</aside><aside id="wpcom_instagram_widget-5" class="widget widget_wpcom_instagram_widget"><h3 class="widgettitle">UNCUT Instagram Feed</h3><p>There was an error retrieving images from Instagram. An attempt will be remade in a few minutes.</p></aside><aside id="top-posts-5" class="widget widget_top-posts"><h3 class="widgettitle">Top Posts &amp; Pages</h3><ul class='widgets-list-layout no-grav'>
					<li>
												<a href="https://uncutmagazine.net/2007/07/10/garcelle-beauvais-in-playboy/" title="Garcelle Beauvais in Playboy" class="bump-view" data-bump-view="tp">
							<img width="40" height="40" src="https://i1.wp.com/i64.photobucket.com/albums/h164/ybfchic/July%2007/garcelle.jpg?resize=40%2C40" class='widgets-list-layout-blavatar' alt="Garcelle Beauvais in Playboy" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://uncutmagazine.net/2007/07/10/garcelle-beauvais-in-playboy/" class="bump-view" data-bump-view="tp">
								Garcelle Beauvais in Playboy							</a>
						</div>
											</li>
									<li>
												<a href="https://uncutmagazine.net/2009/02/17/aubrey-odays-full-playboy-spread/" title="Aubrey O&#039;Day&#039;s Full Playboy Spread" class="bump-view" data-bump-view="tp">
							<img width="40" height="40" src="https://uncutmag.files.wordpress.com/2009/02/2e6d4-aubrey_playboy7.jpg?resize=40%2C40" class='widgets-list-layout-blavatar' alt="Aubrey O&#039;Day&#039;s Full Playboy Spread" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://uncutmagazine.net/2009/02/17/aubrey-odays-full-playboy-spread/" class="bump-view" data-bump-view="tp">
								Aubrey O&#039;Day&#039;s Full Playboy Spread							</a>
						</div>
											</li>
									<li>
												<a href="https://uncutmagazine.net/2015/06/29/uncut-knockout-of-the-week-lia-daniels/" title="UNCUT Knockout Of The Week *Lia Daniels*" class="bump-view" data-bump-view="tp">
							<img width="40" height="40" src="https://uncutmag.files.wordpress.com/2015/06/lia-daniels4.jpg?resize=40%2C40" class='widgets-list-layout-blavatar' alt="UNCUT Knockout Of The Week *Lia Daniels*" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://uncutmagazine.net/2015/06/29/uncut-knockout-of-the-week-lia-daniels/" class="bump-view" data-bump-view="tp">
								UNCUT Knockout Of The Week *Lia Daniels*							</a>
						</div>
											</li>
									<li>
												<a href="https://uncutmagazine.net/2015/07/06/uncut-knockout-of-the-week-paris-milan/" title="UNCUT Knockout Of The Week *Paris Milan*" class="bump-view" data-bump-view="tp">
							<img width="40" height="40" src="https://uncutmag.files.wordpress.com/2013/12/229cb-parismilan5.jpg?resize=40%2C40" class='widgets-list-layout-blavatar' alt="UNCUT Knockout Of The Week *Paris Milan*" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://uncutmagazine.net/2015/07/06/uncut-knockout-of-the-week-paris-milan/" class="bump-view" data-bump-view="tp">
								UNCUT Knockout Of The Week *Paris Milan*							</a>
						</div>
											</li>
									<li>
												<a href="https://uncutmagazine.net/2015/07/13/uncut-knockout-of-the-week-cayenne-wesley/" title="UNCUT Knockout Of The Week *Cayenne Wesley*" class="bump-view" data-bump-view="tp">
							<img width="40" height="40" src="https://uncutmag.files.wordpress.com/2014/08/6d56a-cayennewesley6-uncutmagazine-net.jpg?resize=40%2C40" class='widgets-list-layout-blavatar' alt="UNCUT Knockout Of The Week *Cayenne Wesley*" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://uncutmagazine.net/2015/07/13/uncut-knockout-of-the-week-cayenne-wesley/" class="bump-view" data-bump-view="tp">
								UNCUT Knockout Of The Week *Cayenne Wesley*							</a>
						</div>
											</li>
				</ul>
</aside><aside id="archives-4" class="widget widget_archive"><h3 class="widgettitle">Archives</h3>		<ul>
			<li><a href='https://uncutmagazine.net/2017/11/'>November 2017</a></li>
	<li><a href='https://uncutmagazine.net/2017/10/'>October 2017</a></li>
	<li><a href='https://uncutmagazine.net/2017/09/'>September 2017</a></li>
	<li><a href='https://uncutmagazine.net/2017/08/'>August 2017</a></li>
	<li><a href='https://uncutmagazine.net/2017/07/'>July 2017</a></li>
	<li><a href='https://uncutmagazine.net/2017/06/'>June 2017</a></li>
	<li><a href='https://uncutmagazine.net/2017/05/'>May 2017</a></li>
	<li><a href='https://uncutmagazine.net/2017/04/'>April 2017</a></li>
	<li><a href='https://uncutmagazine.net/2017/03/'>March 2017</a></li>
	<li><a href='https://uncutmagazine.net/2017/02/'>February 2017</a></li>
	<li><a href='https://uncutmagazine.net/2017/01/'>January 2017</a></li>
	<li><a href='https://uncutmagazine.net/2016/12/'>December 2016</a></li>
	<li><a href='https://uncutmagazine.net/2016/11/'>November 2016</a></li>
	<li><a href='https://uncutmagazine.net/2016/10/'>October 2016</a></li>
	<li><a href='https://uncutmagazine.net/2016/09/'>September 2016</a></li>
	<li><a href='https://uncutmagazine.net/2016/08/'>August 2016</a></li>
	<li><a href='https://uncutmagazine.net/2016/01/'>January 2016</a></li>
	<li><a href='https://uncutmagazine.net/2015/12/'>December 2015</a></li>
	<li><a href='https://uncutmagazine.net/2015/11/'>November 2015</a></li>
	<li><a href='https://uncutmagazine.net/2015/10/'>October 2015</a></li>
	<li><a href='https://uncutmagazine.net/2015/09/'>September 2015</a></li>
	<li><a href='https://uncutmagazine.net/2015/07/'>July 2015</a></li>
	<li><a href='https://uncutmagazine.net/2015/06/'>June 2015</a></li>
	<li><a href='https://uncutmagazine.net/2015/05/'>May 2015</a></li>
	<li><a href='https://uncutmagazine.net/2015/04/'>April 2015</a></li>
	<li><a href='https://uncutmagazine.net/2015/03/'>March 2015</a></li>
	<li><a href='https://uncutmagazine.net/2015/02/'>February 2015</a></li>
	<li><a href='https://uncutmagazine.net/2014/08/'>August 2014</a></li>
	<li><a href='https://uncutmagazine.net/2014/07/'>July 2014</a></li>
	<li><a href='https://uncutmagazine.net/2014/06/'>June 2014</a></li>
	<li><a href='https://uncutmagazine.net/2014/05/'>May 2014</a></li>
	<li><a href='https://uncutmagazine.net/2014/04/'>April 2014</a></li>
	<li><a href='https://uncutmagazine.net/2014/03/'>March 2014</a></li>
	<li><a href='https://uncutmagazine.net/2014/02/'>February 2014</a></li>
	<li><a href='https://uncutmagazine.net/2014/01/'>January 2014</a></li>
	<li><a href='https://uncutmagazine.net/2013/12/'>December 2013</a></li>
	<li><a href='https://uncutmagazine.net/2013/11/'>November 2013</a></li>
	<li><a href='https://uncutmagazine.net/2013/10/'>October 2013</a></li>
	<li><a href='https://uncutmagazine.net/2013/09/'>September 2013</a></li>
	<li><a href='https://uncutmagazine.net/2013/08/'>August 2013</a></li>
	<li><a href='https://uncutmagazine.net/2013/07/'>July 2013</a></li>
	<li><a href='https://uncutmagazine.net/2013/06/'>June 2013</a></li>
	<li><a href='https://uncutmagazine.net/2011/10/'>October 2011</a></li>
	<li><a href='https://uncutmagazine.net/2011/09/'>September 2011</a></li>
	<li><a href='https://uncutmagazine.net/2011/08/'>August 2011</a></li>
	<li><a href='https://uncutmagazine.net/2011/07/'>July 2011</a></li>
	<li><a href='https://uncutmagazine.net/2011/06/'>June 2011</a></li>
	<li><a href='https://uncutmagazine.net/2011/05/'>May 2011</a></li>
	<li><a href='https://uncutmagazine.net/2011/04/'>April 2011</a></li>
	<li><a href='https://uncutmagazine.net/2011/03/'>March 2011</a></li>
	<li><a href='https://uncutmagazine.net/2011/02/'>February 2011</a></li>
	<li><a href='https://uncutmagazine.net/2011/01/'>January 2011</a></li>
	<li><a href='https://uncutmagazine.net/2010/12/'>December 2010</a></li>
	<li><a href='https://uncutmagazine.net/2010/11/'>November 2010</a></li>
	<li><a href='https://uncutmagazine.net/2010/10/'>October 2010</a></li>
	<li><a href='https://uncutmagazine.net/2010/09/'>September 2010</a></li>
	<li><a href='https://uncutmagazine.net/2010/08/'>August 2010</a></li>
	<li><a href='https://uncutmagazine.net/2010/07/'>July 2010</a></li>
	<li><a href='https://uncutmagazine.net/2010/06/'>June 2010</a></li>
	<li><a href='https://uncutmagazine.net/2010/05/'>May 2010</a></li>
	<li><a href='https://uncutmagazine.net/2010/04/'>April 2010</a></li>
	<li><a href='https://uncutmagazine.net/2010/03/'>March 2010</a></li>
	<li><a href='https://uncutmagazine.net/2010/02/'>February 2010</a></li>
	<li><a href='https://uncutmagazine.net/2010/01/'>January 2010</a></li>
	<li><a href='https://uncutmagazine.net/2009/12/'>December 2009</a></li>
	<li><a href='https://uncutmagazine.net/2009/11/'>November 2009</a></li>
	<li><a href='https://uncutmagazine.net/2009/10/'>October 2009</a></li>
	<li><a href='https://uncutmagazine.net/2009/09/'>September 2009</a></li>
	<li><a href='https://uncutmagazine.net/2009/08/'>August 2009</a></li>
	<li><a href='https://uncutmagazine.net/2009/07/'>July 2009</a></li>
	<li><a href='https://uncutmagazine.net/2009/06/'>June 2009</a></li>
	<li><a href='https://uncutmagazine.net/2009/05/'>May 2009</a></li>
	<li><a href='https://uncutmagazine.net/2009/04/'>April 2009</a></li>
	<li><a href='https://uncutmagazine.net/2009/03/'>March 2009</a></li>
	<li><a href='https://uncutmagazine.net/2009/02/'>February 2009</a></li>
	<li><a href='https://uncutmagazine.net/2009/01/'>January 2009</a></li>
	<li><a href='https://uncutmagazine.net/2008/12/'>December 2008</a></li>
	<li><a href='https://uncutmagazine.net/2008/11/'>November 2008</a></li>
	<li><a href='https://uncutmagazine.net/2008/10/'>October 2008</a></li>
	<li><a href='https://uncutmagazine.net/2008/09/'>September 2008</a></li>
	<li><a href='https://uncutmagazine.net/2008/08/'>August 2008</a></li>
	<li><a href='https://uncutmagazine.net/2008/07/'>July 2008</a></li>
	<li><a href='https://uncutmagazine.net/2008/06/'>June 2008</a></li>
	<li><a href='https://uncutmagazine.net/2008/05/'>May 2008</a></li>
	<li><a href='https://uncutmagazine.net/2008/04/'>April 2008</a></li>
	<li><a href='https://uncutmagazine.net/2008/03/'>March 2008</a></li>
	<li><a href='https://uncutmagazine.net/2008/02/'>February 2008</a></li>
	<li><a href='https://uncutmagazine.net/2008/01/'>January 2008</a></li>
	<li><a href='https://uncutmagazine.net/2007/12/'>December 2007</a></li>
	<li><a href='https://uncutmagazine.net/2007/11/'>November 2007</a></li>
	<li><a href='https://uncutmagazine.net/2007/10/'>October 2007</a></li>
	<li><a href='https://uncutmagazine.net/2007/09/'>September 2007</a></li>
	<li><a href='https://uncutmagazine.net/2007/08/'>August 2007</a></li>
	<li><a href='https://uncutmagazine.net/2007/07/'>July 2007</a></li>
	<li><a href='https://uncutmagazine.net/2007/06/'>June 2007</a></li>
	<li><a href='https://uncutmagazine.net/2007/05/'>May 2007</a></li>
	<li><a href='https://uncutmagazine.net/2007/04/'>April 2007</a></li>
	<li><a href='https://uncutmagazine.net/2007/03/'>March 2007</a></li>
	<li><a href='https://uncutmagazine.net/2007/02/'>February 2007</a></li>
	<li><a href='https://uncutmagazine.net/2007/01/'>January 2007</a></li>
	<li><a href='https://uncutmagazine.net/2006/12/'>December 2006</a></li>
		</ul>
		</aside><aside id="meta-3" class="widget widget_meta"><h3 class="widgettitle">https://uncutmagazine.net/feed/ </h3>			<ul>
			<li><a href="https://wordpress.com/start?ref=wplogin">Register</a></li>			<li><a href="https://uncutmag.wordpress.com/wp-login.php">Log in</a></li>
			<li><a href="https://uncutmagazine.net/feed/">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://uncutmagazine.net/comments/feed/">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://wordpress.com/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.com</a></li>			</ul>
			</aside>
</section>
	</div>


		<div id="footer-wrap">

			<footer id="footer" class="container clearfix" role="contentinfo">
				<div id="credit-link">
					<a href="https://wordpress.com/?ref=footer_blog">Blog at WordPress.com.</a> 
									</div>
			</footer>

		</div>

</div><!-- end #wrapper -->

<!--  -->
<script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201746y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/uncutmag.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/uncutmag.wordpress.com\/wp-login.php?action=logout&_wpnonce=f1f34894d2","homeURL":"https:\/\/uncutmagazine.net\/","postID":"39285","gravDefault":"identicon","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"0","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1479964158j'></script>

	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="6828512" />
				<input type="hidden" id="carousel-reblog-blog-url" value="https://uncutmagazine.net" />
				<input type="hidden" id="carousel-reblog-blog-title" value="UNCUTmagazine.net" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="9f87ea561c" /><input type="hidden" name="_wp_http_referer" value="/2017/11/17/new-music-curreny-ft-young-roddy-long-as-it-lasts/" />		</form>

		<div class="arrow"></div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/uncutmagazine.net\/2017\/11\/17\/new-music-curreny-ft-young-roddy-long-as-it-lasts\/":39285};
	</script>
		<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-facebook' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-twitter' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-google-plus-1' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-tumblr' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-linkedin' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
		});
		</script>
							<script type="text/javascript">
				jQuery(document).on('ready', function(){
					jQuery('body').on('click', 'a.share-pinterest', function(e){
						e.preventDefault();
						// Load Pinterest Bookmarklet code
						var s = document.createElement("script");
						s.type = "text/javascript";
						s.src = window.location.protocol + "//assets.pinterest.com/js/pinmarklet.js?r=" + ( Math.random() * 99999999 );
						var x = document.getElementsByTagName("script")[0];
						x.parentNode.insertBefore(s, x);
						// Trigger Stats
						var s = document.createElement("script");
						s.type = "text/javascript";
						s.src = this + ( this.toString().indexOf( '?' ) ? '&' : '?' ) + 'js_only=1';
						var x = document.getElementsByTagName("script")[0];
						x.parentNode.insertBefore(s, x);
					});
				});
			</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-pocket' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
		});
		</script>
			<div id="sharing_email" style="display: none;">
		<form action="/2017/11/17/new-music-curreny-ft-young-roddy-long-as-it-lasts/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" />
			<script> document.getElementById('jetpack-source_f_name').value = ''; </script>
			<div class="recaptcha" id="sharing_recaptcha"></div><input type="hidden" name="recaptcha_public_key" id="recaptcha_public_key" value="6LcYW8MSAAAAADBAuEH9yaPcF7lWh11Iq62ZKtoo" />
			<img style="float: right; display: none" class="loading" src="https://s2.wp.com/wp-content/mu-plugins/post-flair/sharing/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<link rel='stylesheet' id='all-css-0-3' href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1481571546h' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel-ie8fix.css?m=1412618825h&#038;ver=20121024' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='all-css-2-3' href='https://s0.wp.com/_static/??-eJzTLy/QzcxLzilNSS3WzyrWz01NyUxMzUnNTc0rQeEU5CRWphbp5qSmJyZX6uVm5uklFxfr6OPTDpRD5sM02efaGpoaWJobmplYmmYBAHQdL1Q=' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var comment_like_text = {"loading":"Loading..."};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var actionbardata = {"siteID":"6828512","siteName":"UNCUTmagazine.net","siteURL":"https:\/\/uncutmagazine.net","icon":"<img alt='' src='https:\/\/secure.gravatar.com\/blavatar\/a8dbc2a8eada1bca9b728be42a57c79c?s=50&d=https%3A%2F%2Fs1.wp.com%2Fi%2Flogo%2Fwpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"premium\/dynamic-news","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/uncutmag.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Funcutmagazine.net%2F2017%2F11%2F17%2Fnew-music-curreny-ft-young-roddy-long-as-it-lasts%2F","themeURL":"https:\/\/wordpress.com\/theme\/dynamic-news\/","xhrURL":"https:\/\/uncutmagazine.net\/wp-admin\/admin-ajax.php","nonce":"f0a16d591f","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"c36e322463\" \/>","referer":"https:\/\/uncutmagazine.net\/2017\/11\/17\/new-music-curreny-ft-young-roddy-long-as-it-lasts\/","canFollow":"1","feedID":"49692593","statusMessage":"","customizeLink":"https:\/\/uncutmag.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Funcutmag.wordpress.com%2F2017%2F11%2F17%2Fnew-music-curreny-ft-young-roddy-long-as-it-lasts%2F","postID":"39285","shortlink":"https:\/\/wp.me\/psEpi-adD","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/uncutmagazine.net\/39285","statsLink":"https:\/\/wordpress.com\/stats\/post\/39285\/uncutmagazine.net","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: Dynamic News","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in Reader","viewReadPost":"View post in Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"Join 6,339 other followers","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/uncutmag.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Funcutmagazine.net%2F2017%2F11%2F17%2Fnew-music-curreny-ft-young-roddy-long-as-it-lasts%2F\">Log in now.<\/a>","stats":"Stats"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/uncutmagazine.net\/wp-admin\/admin-ajax.php","nonce":"8264271c86","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/uncutmag.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Funcutmagazine.net%2F2017%2F11%2F17%2Fnew-music-curreny-ft-young-roddy-long-as-it-lasts%2F","blog_id":"6828512","local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=6828512&v=wpcom&tz=-5&user_id=0&subd=uncutmag","is_public":"1","reblog_enabled":""};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript'>
var mejsL10n = {"language":"en","strings":{"mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen-off":"Turn off Fullscreen","mejs.fullscreen-on":"Go Fullscreen","mejs.download-video":"Download Video","mejs.fullscreen":"Fullscreen","mejs.time-jump-forward":["Jump forward 1 second","Jump forward %1 seconds"],"mejs.loop":"Toggle Loop","mejs.play":"Play","mejs.pause":"Pause","mejs.close":"Close","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.time-skip-back":["Skip back 1 second","Skip back %1 seconds"],"mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.mute-toggle":"Mute Toggle","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.ad-skip":"Skip ad","mejs.ad-skip-info":["Skip in 1 second","Skip in %1 seconds"],"mejs.source-chooser":"Source Chooser","mejs.stop":"Stop","mejs.speed-rate":"Speed Rate","mejs.live-broadcast":"Live Broadcast","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJyVktFuwyAMRX9olFZbN/Vh2qdMDripCQZmSLv8/ejaVJmURuuT4XKPMTb6lJSJoWAo2mVt8UgG0/fK5Sc9OeJeJd+3FLL21GHWXz32eIBgPcqC2UTmKqkL5M50o/OJEj4C/REWQIclgen0JwWj92CwibFTyA3aBQosU1ANiGbIBaWuVDyiCNl6/U17MEORWslSsWAKxXCGbqvRXcv3vb28PScKc7qrE5DhGlZT11xHQWKf0Y8dUqMwl5nREqBH/k0y2ag67poShjpynq/qPsvUChT8F1jPpvt7zPgtBJMfpqa5bneUGYt6Xq2v3yMKL/hTzEXtPZDofACh0I6xQh/8vtmud2+b15fd1v0AVAc4mw=='></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script><script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'6828512','blog_tz':'-5','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'6828512','v':'wpcom','tz':'-5','user_id':'0','post':'39285','subd':'uncutmag'}]);
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1wamRFTUJvcCVmdVtvcCUrditEcC45PytzMjM4V29tOXpbNnl3W0stblBralVYJnMlLTd1UU5MWSYzVnIvbXRWUmVOYlVaVlQvY292RzE/eEJxL1N8RU5NbSVkdVVCRWduLl18X2UrRWxJcz1oNVsxVlNnNWxwYz1OaiVZZF8/YnBMQXJdaGFdLlZONXx6ZlFIeHk5UGJGY0RBcmJkMklkaGk0WGFHLXFUZUd2cHFJYVIrTFZXd1l8TXMwMj16ZV9lWy9pclguU1hPPXVLMlFXOX5ibzEwcjJPdHBIUGElYnBWVXJzaHQlZXhHM0Q1fHNbby1ZfmNRUGUuMW1DaS0zRD9URDZmd009T1t0eUxaOGFdRXx8W3FwNUM5M0Y0V11mOGNwR1NoK1taRWJlWitSTmpINnZpMH58NVBFSGNYclo1THA0MWxkMyxMYU4/b2NyN28lL3JaR25zQ1MwQSVPOHFSbXFqdi11aWE='}]);
_stq.push([ 'clickTrackerInit', '6828512', '39285' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>